use strict;
my $str = 'foo
bar
Lorem ipsum
baz
hello world!
test
done!';
my $regex = qr/\n{2,}/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";