re = /\n{2,}/m
str = 'foo
bar
Lorem ipsum
baz
hello world!
test
done!'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result