#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[caption([^\]]+)align="([^"]+)"\s+width="(\d+)"\](\s*\<img[^>]+>)\s*(.*?)\s*\[\/caption\]"
Local $sString = "[caption id="attachment_666" align="alignleft" width="316"]" & @CRLF & _
" <img class="wp-image-92692" src="img" width="316" alt="fitbit-yoga-lady.png" height="210"> " & @CRLF & _
" text" & @CRLF & _
"[/caption]"
Local $sSubst = "<div\1style="width: \3px" class="wp-caption \2">\4\n <p class="caption">\5</p>\n</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)