using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[caption([^\]]+)align=""([^""]+)""\s+width=""(\d+)""\](\s*\<img[^>]+>)\s*(.*?)\s*\[\/caption\]";
string substitution = @"<div\1style=""width: \3px"" class=""wp-caption \2"">\4\n <p class=""caption"">\5</p>\n</div>";
string input = @"[caption id=""attachment_666"" align=""alignleft"" width=""316""]
<img class=""wp-image-92692"" src=""img"" width=""316"" alt=""fitbit-yoga-lady.png"" height=""210"">
text
[/caption]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}