$re = '/(Technology libraries: )(.*)/m';
$str = 'Technology libraries: Techlibhellohellohello';
$subst = "\n$1\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;