package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{value\=(([a-z|A-Z|(0-9)*|\s+|\w+]*))\}\}`)
var str = `{value=Parking Bay Suspension}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}