package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1-?1-?1-?1-?2-?2-?2-?2`)
var str = `1111-2222 and 11112222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}