$re = '/1-?1-?1-?1-?2-?2-?2-?2/m';
$str = '1111-2222 and 11112222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);