package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s-]+-?|-`)
var str = `Self-Sizing Text in a Circle
abc-----def ghi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}