package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+?)\/(\S+?)\/?$`)
var str = `/a/b
/a/b/
/document/data/
/document/data
/docs/article1/
/docs/article1`
var substitution = "$1/$2.md"
fmt.Println(re.ReplaceAllString(str, substitution))
}