using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Order[0-9])(?!.*\1)";
string input = @"<ctx>
<PostCode>XXXXXX</PostCode>
<Title1>Mr</Title1>
<Name>John</Name>
<Order1>£100.00</Order1>
<Order2>£100.01</Order2>
<Order3>£100.01</Order3>
<Order4>£100.01</Order4>
<Order5>£100.01</Order5>
<Order6>£100.01</Order6>
<Order7>£100.01</Order7>
<Order8>£100.01</Order8>
<Order9>£100.01</Order9>
<Order10>£100.01</Order10>
<Order11>£100.01</Order11>
<Order50>£100.01</Order50>
<Date>10/10/2010</Date>
</ctx>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}