$re = '/Can I have(?:(?!\s*please).)*/m';
$str = 'RANDOMNUMBERS Can I have some milk please or RANDOMNUMBERS Can I have some milk
RANDOMNUMBERS Can I have more toast please
RANDOMNUMBERS Can I have more toast';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);