using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\d\b)";
string substitution = @"0\1";
string input = @"8 5E 9C 52 30 0";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}