using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"For .+EachIn .+;";
string substitution = @"";
string input = @" foreach (var VARIABLE in COLLECTION)
{
}
For Local tUiObj ob=EachIn tScreen.Active().sub;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}