const regex = /For .+EachIn .+;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('For .+EachIn .+;', 'gm')
const str = ` foreach (var VARIABLE in COLLECTION)
{
}
For Local tUiObj ob=EachIn tScreen.Active().sub;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);