$re = '/For .+EachIn .+;/m';
$str = ' foreach (var VARIABLE in COLLECTION)
{
}
For Local tUiObj ob=EachIn tScreen.Active().sub;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;