const regex = new RegExp('<span class=\\"select\\"[\\w\\d\\s\\"=<>:./]*><a href=[\\w\\d\\s\\"<>:/.-]+</a></span>', 'gm')
const str = `<span class="select" foo="1<>/"><a href="https://www.domain.tld">Word 1</a></span><span class="select"><a href="https://www.domain.tld">Word 2</a></span><span class="no_select"><a href="https://www.domain.tld">Word 3</a></span><span class="select" bar="2"><a href="https://www.domain.tld">Word 4</a></span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}