// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<span class=\"select\"[\w\d\s\"=<>:./]*><a href=[\w\d\s\"<>:/.-]+</a></span>"#).unwrap();
let string = "<span class=\"select\" foo=\"1<>/\"><a href=\"https://www.domain.tld\">Word 1</a></span><span class=\"select\"><a href=\"https://www.domain.tld\">Word 2</a></span><span class=\"no_select\"><a href=\"https://www.domain.tld\">Word 3</a></span><span class=\"select\" bar=\"2\"><a href=\"https://www.domain.tld\">Word 4</a></span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}