$re = '/939642:(?!.*939642)/m';
$str = '939642:first 939642:second 939642:third';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);