re = /^(?:1[01][0-9]|120|1[7-9]|[2-9][0-9])$/m
str = '1
16
17
99
100
111
120
121
999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end