re = /\B(?=\d*\.)(?=(\d{3})+(?!\d))/m
str = '803427325.0326'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result