#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<browser>Android)\s(?P<major_version>\d+)\.(?P<minor_version>\d+\.?\d?);(?P<lang>\spt-br){0,1};{0,1}(?P<device>[ \w\-?]+)\s"
Local $sString = "20-03-2017 17:26:39" & @CRLF & _
"GET /ourapps.php HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"HTTP headers:" & @CRLF & _
"Accept-Language: pt-BR,en-US;q=0.8" & @CRLF & _
"Accept-Encoding: gzip, deflate" & @CRLF & _
"User-Agent: Mozilla/5.0 (Linux; Android 5.1; 4017F Build/LMY47I; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/43.0.2357.121 Mobile Safari/537.36" & @CRLF & _
"Accept: application/json, text/plain, */*" & @CRLF & _
"Connection: close" & @CRLF & _
"" & @CRLF & _
"20-03-2017 20:17:08" & @CRLF & _
"GET /ourapps.php HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"HTTP headers:" & @CRLF & _
"Accept-Charset: utf-8, iso-8859-1, utf-16, *;q=0.7" & @CRLF & _
"Accept-Language: pt-BR, en-US" & @CRLF & _
"Accept-Encoding: gzip,deflate" & @CRLF & _
"X-Wap-Profile: http://gsm.lge.com/html/gsm/E467f-M3-D1.xml" & @CRLF & _
"User-Agent: Mozilla/5.0 (Linux; U; Android 4.1.2; pt-br; LG-E467f Build/JZO54K) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30" & @CRLF & _
"Accept: application/json, text/plain, */*" & @CRLF & _
"Connection: close" & @CRLF & _
"" & @CRLF & _
"20-03-2017 21:09:36" & @CRLF & _
"GET /ourapps.php HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"HTTP headers:" & @CRLF & _
"Accept-Language: pt-BR,en-US;q=0.8" & @CRLF & _
"Accept-Encoding: gzip,deflate" & @CRLF & _
"User-Agent: Mozilla/5.0 (Linux; Android 4.4.2; SM-G355M Build/KOT49H) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.36" & @CRLF & _
"Accept: application/json, text/plain, */*" & @CRLF & _
"Connection: close" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")