using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$";
string input = @"https://my.site.com
https://my.site.com/
https://my.site.com/about
https://my.site.com/about/
https://my.site.com/about?query=string
https://my.site.com/about/?query=string
https://my.site.com/about#TestAnchor
https://my.site.com/about/#TestAnchor
https://my.site.com/about?query=string#TestAnchor
https://my.site.com/about/?query=string#TestAnchor
https://my.site.com/about-us
https://my.site.com/about-us/
https://my.site.com/about/us
https://my.site.com/about/us/
https://my.site.com/about/us/more/path
https://my.site.com/about/us/more/path/
https://my.site.com/about/us/more/path?query=string
https://my.site.com/about/us/more/path/?query=string
https://my.site.com/about/us/more/path#TestAnchor
https://my.site.com/about/us/more/path/#TestAnchor
https://my.site.com/about/us/more/path?query=string#TestAnchor
https://my.site.com/about/us/more/path/?query=string#TestAnchor";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}