use strict;
my $str = 'https://my.site.com
https://my.site.com/
https://my.site.com/about
https://my.site.com/about/
https://my.site.com/about?query=string
https://my.site.com/about/?query=string
https://my.site.com/about#TestAnchor
https://my.site.com/about/#TestAnchor
https://my.site.com/about?query=string#TestAnchor
https://my.site.com/about/?query=string#TestAnchor
https://my.site.com/about-us
https://my.site.com/about-us/
https://my.site.com/about/us
https://my.site.com/about/us/
https://my.site.com/about/us/more/path
https://my.site.com/about/us/more/path/
https://my.site.com/about/us/more/path?query=string
https://my.site.com/about/us/more/path/?query=string
https://my.site.com/about/us/more/path#TestAnchor
https://my.site.com/about/us/more/path/#TestAnchor
https://my.site.com/about/us/more/path?query=string#TestAnchor
https://my.site.com/about/us/more/path/?query=string#TestAnchor';
my $regex = qr/^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}