import Foundation
let pattern = ##"^((?:https?:\/\/[\w\.\-]*)(?:[\w\-]+\/)*(?:[\w\-]+)(?!\/))(\?.*?)?(\#.*?)?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://my.site.com
https://my.site.com/
https://my.site.com/about
https://my.site.com/about/
https://my.site.com/about?query=string
https://my.site.com/about/?query=string
https://my.site.com/about#TestAnchor
https://my.site.com/about/#TestAnchor
https://my.site.com/about?query=string#TestAnchor
https://my.site.com/about/?query=string#TestAnchor
https://my.site.com/about-us
https://my.site.com/about-us/
https://my.site.com/about/us
https://my.site.com/about/us/
https://my.site.com/about/us/more/path
https://my.site.com/about/us/more/path/
https://my.site.com/about/us/more/path?query=string
https://my.site.com/about/us/more/path/?query=string
https://my.site.com/about/us/more/path#TestAnchor
https://my.site.com/about/us/more/path/#TestAnchor
https://my.site.com/about/us/more/path?query=string#TestAnchor
https://my.site.com/about/us/more/path/?query=string#TestAnchor
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)