#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https{0,1}:\/\/)"
Local $sString = "https://regex101.com" & @CRLF & _
"https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly" & @CRLF & _
"http://www.regular-expressions.info/optional.html" & @CRLF & _
"https://www.youtube.com/watch?v=iA9DlBSMQ4c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")