using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https{0,1}:\/\/)";
string input = @"https://regex101.com
https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly
http://www.regular-expressions.info/optional.html
https://www.youtube.com/watch?v=iA9DlBSMQ4c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}