import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https{0,1}:\\/\\/)";
final String string = "https://regex101.com\n"
+ "https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly\n"
+ "http://www.regular-expressions.info/optional.html\n"
+ "https://www.youtube.com/watch?v=iA9DlBSMQ4c";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}