const regex = /(https{0,1}:\/\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https{0,1}:\\\/\\\/)', 'gm')
const str = `https://regex101.com
https://stackoverflow.com/questions/57601242/why-is-this-regex-expression-not-matching-the-string-exactly
http://www.regular-expressions.info/optional.html
https://www.youtube.com/watch?v=iA9DlBSMQ4c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}