#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((\d{1,3}(?:\s\d{3})*)\)"
Local $sString = "National Museum 4.6(1 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00" & @CRLF & _
"National Museum 4.6(12 686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00" & @CRLF & _
"National Museum 4.6(686), Museum, Green Street 24/26, Some description, Closing: md.. 20:00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")