$re = '/./';
$str = 'An de snou frai and de colei grei Chicago mun beby beibi Charlis morlis de In the guetto (In the guetooo). An de jar mama crai Cosinifi guan sido sido ni modrili yian grin monfi in de gue e to.
[my_shortcode id="1" type="lorem"]lorem ipsum dolor sit amet[/my_shortcode]
Pipol yon ondre tain de chili jil pija. E jil grou yon gui yon man dei. Toque lo que yu an mi. A güi chi blai chu si. De güi simpli ten an qüen. Anblon delon de güei Güedengüelten.
[my_shortcode id="2" type="In-sollicitudin"]In sollicitudin
ullamcorper dolor[/my_shortcode]
A de güelguei jei qui lo you güi re ni brus prisis tri yi guai brus in de guetoooo. An de jan gai ben. So si estarer churruan estrit nai li chus tul fili ji fanch fisin de gueto (In the guetooo).';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);