package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)attr_itx_media_type\s+\[str\]\s+\=\s+\"(?<attr_itx_media_type>[^\"]+)\"`)
var str = `attr_itx_media_type [str] = "voicePerdida"
attr_itx_media_type [str] = "smsCustom"
attr_itx_media_type [str] = "email"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}