import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "attr_itx_media_type\\s+\\[str\\]\\s+\\=\\s+\\\"(?<attr_itx_media_type>[^\\\"]+)\\\"";
final String string = "attr_itx_media_type [str] = \"voicePerdida\"\n"
+ "attr_itx_media_type [str] = \"smsCustom\"\n"
+ "attr_itx_media_type [str] = \"email\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}