$re = '/^[^_]*_OPC\K[^_]+/';
$str = 'MP700000001_OPC32_812345643';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);