$re = '/\s*(?:\$\d+\s*)+/m';
$str = '$1 $2 $3 $5 $7 hello';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;