using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|[12][0-9]))(?:\2|\5|\8)((?:16|[357][26]|[2468][048])(?:[0248][048]|[13579][26])|(?:1[6-9]|[2-9][0-9])(?:0[48]|[13579][26]|[2468][048])|(?:15)(?:84|9[048]))|(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|1[0-9]|2[0-8]))(?:\12|\15|\18)((?:16|[357][26]|[2468][048])(?:0[1235679]|[13579][01345789]|[2468][1235679])|(?:1[789]|[35679][01345789]|[248][12345679])(?:0[01235679]|[13579][01345789]|[2468][1235679])|(?:15)(?:8[235679]|9[01345789])))$";
string input = @"2-2-2016";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}