#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^AB_INV_[0-4](?!\d)"
Local $sString = "AB_INV_23_some_value" & @CRLF & _
"AB_INV_5_some_value" & @CRLF & _
"AB_INV_4_some_value" & @CRLF & _
"AB_INV_3_some_value" & @CRLF & _
"AB_INV_2_some_value" & @CRLF & _
"AB_INV_1_some_value" & @CRLF & _
"AB_INV_0_some_value"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")