#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)(?=.swp)"
Local $sString = ".favorite_regexes.txt.swp" & @CRLF & _
".practice.py.swp" & @CRLF & _
".DS_Store" & @CRLF & _
"favorite_regexes.txt" & @CRLF & _
"practice.py" & @CRLF & _
"zippy.py" & @CRLF & _
"" & @CRLF & _
"ab" & @CRLF & _
"cabc" & @CRLF & _
"abd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")