$re = '/^\s+?$/m';
$str = 'Here is some text.
After several lines of whitespace, here is some more text.';
$subst = "<line break>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;