import Foundation
let pattern = #"^\s+?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Here is some text.
After several lines of whitespace, here is some more text.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<line break>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)