// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{4}\s([a-zA-Z]+( [a-zA-Z]+)+)").unwrap();
let string = "2021 Chrysler Pacifica Hybrid Passenger Van
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}