$re = '/.*(\p{L}){2,}.*/';
$str = '322332лд233-
ваыфаы
в43-ава-аа()?::%4
ВАЫЙФУ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);