$re = '/^([\w\'-]+)[ \t]+([\w\'-]+)/m';
$str = 'Peter O\'Toole hi res.jpg
Daniel Day-Lewis.jpg';
$subst = "$2.$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;