const regex = /"([^"]+)"|(.*) </ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]+)"|(.*) <', 'ig')
const str = `peter@pan.com
lucky <jack@pot.com>
"William Tell" <billy@tell.com>
"John Rambo, III" <johnny@rambo.com>
"there, might, be, several, commas inside the quotes" <multiple@commas.com>
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}