use strict;
my $str = 'peter@pan.com
lucky <jack@pot.com>
"William Tell" <billy@tell.com>
"John Rambo, III" <johnny@rambo.com>
"there, might, be, several, commas inside the quotes" <multiple@commas.com>
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
';
my $regex = qr/"([^"]+)"|(.*) </ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}