#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):\s*\b([\w-]+\b(?:\s+and\s+\b[\w-]+)*)\b"
Local $sString = "Product: TLD-1433 infusion Therapy" & @CRLF & _
"Biological: CG0070|Other: n-dodecyl-B-D-maltoside" & @CRLF & _
"Drug: Atezolizumab" & @CRLF & _
"Drug: N-803 and BCG|Drug: N-803" & @CRLF & _
"Drug: Everolimus and Intravesical Gemcitabine" & @CRLF & _
"Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")