$re = '/:\s*\b([\w-]+\b(?:\s+and\s+\b[\w-]+)*)\b/m';
$str = 'Product: TLD-1433 infusion Therapy
Biological: CG0070|Other: n-dodecyl-B-D-maltoside
Drug: Atezolizumab
Drug: N-803 and BCG|Drug: N-803
Drug: Everolimus and Intravesical Gemcitabine
Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);