#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^' "\n]+)\.([^ \n]+)&((?!["'])[^ "'\n])+($|(?=\s))"
Local $sString = "google.com/cool?cool1=yes&cool2=no&cool3=no"" & @CRLF & _
"" & @CRLF & _
"google.com/cool?cool1=yes&cool2=no&cool3=no" & @CRLF & _
"" & @CRLF & _
"url.com¶meter url2.com¶meter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")