using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^' ""\n]+)\.([^ \n]+)&((?![""'])[^ ""'\n])+($|(?=\s))";
string input = @"google.com/cool?cool1=yes&cool2=no&cool3=no""
google.com/cool?cool1=yes&cool2=no&cool3=no
url.com¶meter url2.com¶meter";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}