package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+)+\s\|{3}\s(\w+)\s\|{3}\s(.*)`)
var str = `amornratchatchawansawangwong ||| amornratchatchawansawangwong . ||| 0.594819 0.5 0.594819 0.25 ||| 0-0 0-1 ||| 1 1 1 ||| |||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}